Tournament Planner
(návodka k použití)
Úvod

Přidělení licence BTP a povinnosti pořadatele v souvislosti s jejím používáním se řídí Dodatkem k v rozpisu soutěží – používání BTP (Badminton Tournament Planner).
Instalace BTP a jeho registrace
1) Stáhnout ze stránek Tournament softwaru Badminton Tournament Planner (BTP)

( http://tournamentsoftware.com/product/download.aspx?id=16&s=2 )
2) Nainstalovat BTP

(POZOR – při instalaci se mohou objevit chybové hlášení jako např. Error 1327 Invalid Drive U:\ nebo že nelze vytvořit složku Dokumenty či jiná – tyto případy je potřeba ošetřit individuálně v závislosti na nastavení počítače)
3) Spustit btp.exe

4) Zaregistrovat program s použitím licence (Help – Registration)

Základní nastavení BTP pro nový turnaj

1) Navolit úložiště, kam se budou ukládat TP files (Extra – Options – General - Default Tournament Folder)
2) Navolit zobrazovaní jména v pořadí Lastname, Firstname (Extra – Options – Payer Names – Order)
3) Vždy založit nový turnaj (New Tournament / Ctrl + N)

(pokud by se např. otevřel turnaj z předchozího roku a pouze by se upravily údaje v něm uvedené, došlo by ke smazání původního turnaje na stránkách Tournament softwaru)
POZOR - turnaj umístěný na stránky Tournamentsoftware.co je svázaný s TP souborem a nikoliv s názvem turnaje!
4) Název turnaje – bez interpunkce ve formátu “XXX YYY ZZZZZZ RRRR“ kde je:
XXX - typ turnaje (MCR, GPA, GPB)
YYY - věková kategorie (Veteranu, Dospelych, U19, U17, U15,  U13, U11)
ZZZZZZ - místo konání turnaje (např. Liberec, Hradec Kralove, Cesky Krumlov apod.)
RRRR - aktuální kalendářní rok

Příklad: GPA U17 Benatky nad Jizerou 2011

Výjimkou jsou GPA a GPB turnaje dospělých, kde je název turnaje ve formátu “AAA Turnaj RRRR“ kde je:
AAA - GPB (pouze u turnajů typu GPB) 

Turnaj - název turnaje dle propozic (např. Memorial Holobradeho, Velka cena Plzne apod.)
RRRR - aktuální kalendářní rok

Příklad: Memorial Holobradeho 2010, Velka cena Plzne 2011, GPB Benatecky pohar 2011
5) V Tournament  Properties vyplnit :

a) záložka Info (obecné informace o turnaji)
- Tournament Organizer - Czech Badminton Federation

- Dates – datum konání turnaje (z propozic)

- Draw date – datum losování (většinou sobota)
- Organizer Phone – telefon na organizátora turnaje (z propozic u přihlášek)
- Organizer E-mail – E-mail na organizátora turnaje (z propozic u přihlášek)
- Referee – vrchní rozhodčí
- Referee E-mail – E-mail na vrchního rozhodčího

Netřeba vyplňovat – Tournament Number (číslo turnaje), Weeknumber (číslo týdne), Report Logo 

b) záložka Address (vše by mělo být uvedeno v propozicích turnaje)
- Venue – místo konání turnaje (např. Sportovní hala při ZŠ v Kuklenách)
- Address – adresa sportovní haly, kde se bude turnaj hrát (jméno ulice)
- Postal Code – poštovní směrovací číslo

- City – město

- State – netřeba vyplňovat
- Country – stát

- Time zone – časové pásmo (ponechat předvyplněné)
- Phone, Fax, Email – telefon, fax a Email do haly (netřeba vyplňovat)
- Website – webová stránka turnaje (pokud ji pořadatel uvede do propozic)

c) záložka Events (disciplíny které se budou hrát)

- nejlépe je jednotlivé disciplíny převzít z jiného podobného turnaje – volba Import
- postup při zadávání jednotlivých disciplín je:


- zvolit Add (přidat) a na záložce General pak vyplnit


- název disciplíny bez interpunkce (např. Dvouhra chlapcu)


- Gender (např. Boys, Girls nebo Mixed u smíšené čtyřhry)


- Type (Singles nebo Doubles)


- Level nevyplňovat

- Sep.Seeding zaškrtnout pouze v případě, kdy se hraje odděleně kvalifikace a hlavní soutěž (v Rosteru se tím vytvoří nová záložka Qualifying)

- Min.Age nevyplňovat

- Max.Age maximální věk (např. u kategorie U19 je to 18 let)

- Fee (startovné) dle propozic

- Scoring Format (systém počítání) ponechat předvolený

- na záložce Availability nic nevyplňovat

Tlačítkem Pick lze vybrat z nabízených možností (nepoužívat), tlačítkem Edit lze jednotlivé disciplíny upravit a tlačítkem Delete zrušit.
d) záložka Days (dny ve kterých se bude hrát)

- jednotlivé hrací dny vybrat z kalendáře a tlačítkem Add přidat do seznamu

e) záložka Times (důležité pro časový plán turnaje)

- Times per day doporučuji vyplnit 21 (poslední čas je pak v sobotu 19:00)
- Create (vytvořit) zde lze opět použít již vyzkoušené časové schéma z jiného turnaje

- doporučuje se vytvořit pro sobotu toto časové schéma (tlačítko 1 Day)

Start 9:00, Interval 25 minutes u mládeže a 30 minutes u dospělých a ostatní ponechat beze změny

- pro neděli pak Start 9:00 (dle propozic) a Interval 15 minutes

- pokud nechceme mít stejný interval, můžeme časy doplnit ručně do každého políčka dle vlastního uvážení

f) záložka Locations/Courts (počet kurtů - důležité pro časový plán turnaje)

- označit Main Location a tlačítkem Edit upravíme

- na záložce General


- změnit Main Locationa na název haly (např. Sportovní hala ZŠ)


- tlačítkem Create vytvoříme počet hracích kurtů



- vyplníme počet kurtů



- prefix pro kurty vyplníme Kurt c.



- ponecháme Numbers

- na záložce Address vyplníme stejné údaje jako na záložce Address v Tournament  Properties

- na záložce Available Courts vyplníme počet kurtů. Které máme k dispozici (nejjednodušší je vyplnit použitím tlačítka All Days a potvrzením Yes)

- přidáme-li na záložce Times další časy, nezapomeňte přidat i volné kurty (Available Courts) u těchto časů

g) záložka Round Robins (systém každý s každým)

- nic neměnit

h) záložka Entry Fees (startovné a jiné poplatky)

- změnit pouze výběr Calculation na Based on participation

i) záložka Officials (rozhodčí)

- nic neměnit ani nevyplňovat

j) záložka Score (systém počítání)

- nic neměnit

k) záložka Draws (los/pavouk)
- nastavit pouze “minutes break after match“ na 20 minut

- zaškrtnout “Show order of play grid“ jen v případě, že chci plánovat zápasy na předem určené kurty (např. finále)
- zaškrtnout “Show location in draws“ jen v případě, že se hraje turnaj ve více halách

- ostatní možnosti není potřeba měnit

Po vyplnění všech těchto údajů zveřejníme turnaj na webu www.tournamentsoftware.com
Zveřejnění se provede v menu Internet -> Publish -> Publish

Není potřeba nic měnit, jen pro domácí turnaje zatrhnout možnost zobrazení oddílu – Show Club
Tímto jsou zveřejněny základní informace o turnaji.
Zaslat online odkaz na turnaj (URL adresa na webu tournamentsoftware.com) na email STK stk@czechbadminton.cz
Načtení hráčů a oddílů do BTP

1) Příprava souboru k načtení hráčů do Tournament Planneru
a) stáhnout si aktuální žebříček příslušné věkové kategorie – soubor typu zip, který obsahuje celostátní a krajský žebříček 
b) pro přípravu seznamu přihlášených hráčů používáme krajský žebříček (např. 13-kraje.xls)

c) dle přihlášek (u mládeže dle oblastní nominace) nakopírovat všechny informace z krajského žebříčku (mimo bodů) do souborů Players_Database_TP_Women a Players_Database_TP_Men.  
2) Import oddílů/klubů a hráčů do TP:

a) V menu Player->Import Clubs, pomocí browse zvolit soubor Oddily_CR_TP, pak jen odmačkávat tlačítka 2x next , pak Finish a potvrdit tlačítkem Yes. Dialogové okno zavřeme tlačítkem Close a kluby jsou načteny. 
b) V menu Player->Import Entries, pomocí browse zvolit soubor Players_Databaze_TP_Women resp. Players_Databaze_TP_Men, pak jen odmačkávat 4x tlačítko Next a zaškrtnout všechny 3 disciplíny ve kterých může hráč startovat (později lze hráče lehce vyškrtnout z disciplíny kde nestartuje), pak tlačítko Finish a potvrdit tlačítkem Yes.
POZOR – je nutná kontrola, zda jsou všichni přihlášení hráči přiřazeni k načteným oddílům. To provedeme tak, že klikneme na libovolného hráče, klikneme na tlačítko … (tři tečky za volbou Club) a v zobrazeném oknu zkontrolujeme, zda je hodnota District vyplněna u všech oddílů (Club). Pokud tomu tak není, přiřadíme tomuto oddílu hodnotu District (číslo oblasti) a tuto skutečnost zapíšeme do zprávy vrchního rozhodčího.
3) Úprava startovní listiny

Volba Roster zobrazuje jednotlivé disciplíny. Postupně na záložce Entries v každé disciplíně upravíme startující hráče či páry.
a) Nejprve změníme žebříčkové pořadí u předsazených hráčů (POZOR – ani BTP neumí pracovat s 0, takže používáme pro předsazené hráče záporná čísla)

b) Ve dvouhrách pouze vyřadíme hráče, kteří v ní nestartují (označíme, tlačítkem Delete zrušíme a potvrdíme tlačítkem Yes).
c) Ve čtyřhrách nejprve spárujeme hráče dle přihlášek (dvojklikem vybereme jednoho hráče z páru, v položce Partner vybereme jeho spoluhráče a potvrdíme tlačítkem OK.
Nakonec vyřadíme hráče, kteří v příslušné disciplíně nestartují (označíme, tlačítkem Delete zrušíme a potvrdíme tlačítkem Yes).

d) Ve čtyřhrách pak ještě páry seřadíme dle žebříčku (kliknutím na sloupec Ranking) a nadbytečné páry bez práva účasti přesuneme na Reserve List (pravým tlačítkem klikneme na pár, zvolíme Move To a vybereme Reserve list)
e) Provedeme nasazení hráčů/párů v jednotlivých disciplínách (kliknutím na sloupec Ranking seřadíme hráče/páry, dvojklikem vybereme nasazovaného/ý hráče/pár a v políčku Seed vyplníme nasazení – 1, 2, 3/4 nebo 5/8)
f) PUBLISH startovní listiny v závislosti na typu turnaje dle příslušného RS

Losování turnaje
Volba Roster nám též umožňuje vytvořit “pavouka“ pro jednotlivé disciplíny. Postupně na záložce Draws v každé disciplíně vytvoříme požadovaného “pavouka“.
1) Vytvoření “pavouků“

- pravým tlačítkem klikneme kdekoliv na záložce Draws, zvolíme Add Draw, pro většinu turnajů (bez kvalifikace) vybereme hrací systém Elimination a dáme Next

- zkontrolujeme, zda má “pavouk“ správnou velikost (Size Of Main Draw) pro příslušnou disciplínu (Name, Playoff, Stage a Qalification necháme většinou beze změny) a dáme Next

- přednastavenou hodnotu Consolation měníme pouze v případě, že se hrají zápasy o pořadí poražených hráčů v 1. kole (Custom) a dáme Next (hráče dosazujeme do “pavouka“ zápasů o pořadí ručně).
- zatrhneme Club, Status a dáme Next

V tuto chvíli máme připravený “pavouk“ pro příslušnou disciplínu

2) Losování

- v menu Draw zvolíme Make Draws a vlevo vybereme disciplínu (Event), kterou chceme losovat a dáme Next
- protože jsme si již zkontrolovali startující hráče v Rosteru není třeba se tímto oknem zabývat a tudíž potvrdíme Next

- v Separation vybereme Club (u soutěží dospělých) nebo District (u soutěží mládeže), v Optomization vybereme Separate first round only (dalších dvou výběrů si nevšímáme) a dáme Next

- pokud BTP nenahlásí žádný konflikt, dáme Finish a potvrdíme Yes

V tuto chvíli máme příslušnou disciplínu vylosovanou

Bod 1 a 2 opakujeme pro každou disciplínu

Časový plán turnaje

Časový plán turnaje lze udělat několika způsoby a záleží na vrchním rozhodčím resp. osobě pověřené prací s BTP jaký způsob zvolí.
Nastavení počtu zápasů (které může hráč odehrát za celý den resp. v disciplíně) se doporučuje nastavit takto: 20 – Max matches per day, 10 - Max matches per event per day, 10 - Max singles per day

Volba Matches nám pak přehledně zobrazuje naplánované zápasy

Možnosti vytvoření časového plánu jsou:
- přes menu Draw volbou Schedule Tournament, který nám umožní naplánovat celý turnaj (nedoporučuje se používat)
- pravým tlačítkem na příslušném místě v “pavouku“, kde si pak můžeme vybrat, jestli přiřadíme časy jednotlivým zápasům (Schedule Match) nebo rovnou naplánujeme celé kolo (Schedule Round) příslušné disciplíny

Doporučuje se používat kombinaci plánování času jednotlivých zápasů a celého kola

Je potřeba časově naplánovat všechny zápasy turnaje, protože nenaplánované zápasy se pak neobjeví na záložce Matches na stránkách Tournamentsoftware.com 

Záznamy do BTP

Při zadávání výsledku jednotlivých zápasů do BTP vždy smažte délku trvání zápasu (Duration)
Tisky

Vše co je třeba během turnaje tiskout (pavouky - Draws, pořadí zápasů - Matches, startovné - Players či výsledky - Tournament) se provádí v menu Report.

Příklad: tisk startovného – menu Report->Players->Payments->Group List nechat Club, vybrat na záložce Events všechna Main Draw, stisknout Select a potvrdit OK (pro úsporu papíru při tisku startovného se doporučuje ještě vyexportovat do Excelu a tisknout z něj)
Tvorba výsledkové listiny pro STK

1) Zkontrolovat že je nastaven formát hráčů Příjmení+Jméno . Menu Extra->Options->Plazer Names-> položka Order – Lastname, Firstname
2) V menu Draw->Layout, vlevo vybrat všechny “pavouky” pro hlavní soutěž, vpravo pak vybrat Header= Standard a zaškrtnout Date of Birth a Club

3) V menu Draw->Export to Excel vyexportovat výsledky do souboru Výsledky “Název turnaje”.xls
4) Tento vyexportovaný soubor uložit též jako vysledky.xls
5) V souboru vysledky.xls přejmenovat jednotlivé listy hlavní soutěže (Main Draw) na MS, WS, MD, WD, XD (kvalifikačních listů si nevšímat), uložit a nechat otevřený.

6) Otevřít form_vysledku_10_18.xls, vyplnit hlavičku a stisknout tlačítko Vyplň formuláře výsledků. Poté soubor uložit jako Formulář výsledků “Název turnaje”.xls.
7) Hrají-li se zápasy o pořadí, je nutné ručně opravit pořadí a přidělené body ve formulářích výsledků
8) Hraje-li se kvalifikace je nutno ručně upravit a přidělit body dle RS - Body do žebříčku GP budou přidělovány i hráčům, kteří prohrají v semifinále resp. finále kvalifikační skupiny. Budou ale přiděleny pouze těm hráčům, kteří v příslušné kvalifikační skupině alespoň jednou vyhrají zápas. (volný los se nepovažuje za vyhraný zápas). Finalista kvalifikační skupiny obdrží 40 bodů a semifinalista (pouze v případě více jak 4 členné kvalifikační skupiny) 20 bodů. V případě, že bude v hlavní soutěži více jak 32 hráčů, bude přiděleno 20 bodů pouze poraženým finalistům.
9) Pokud se hrálo jiným systémem než KO pavouk (například tabulka každý s každým), tak pak je třeba vyplnit výsledky ručně 
10) Takto připravený Formulář výsledků ověřit na správnost licencí pomocí webové aplikace na www.czechbadminton.cz, sekce licence, menu Hromadné ověření licencí. Pokud bude u jakéhokoliv hráče informace NENALEZEN, je třeba vyřešit důvod a opravit.
10) Poslat na email STK stk@czechbadminton.cz Výsledky “Název turnaje”.xls, Formulář výsledků “Název turnaje”.xls a TP soubor turnaje. Toto platí jen pro turnaje MČR, GPA a GPB. Výsledky ostatních turnajů se posílají na příslušnou oblastní STK .

